Переполнение буфера в jabberd

Дата публикации:
02.08.2005
Дата изменения:
17.10.2006
Всего просмотров:
944
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
jabberd 2.x
Уязвимые версии: jabberd версии до 2.0s9

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует в файле jid.c при обработке имени пользователя, хоста и компонентов ресурса. Удаленный пользователь может послать слишком длинную строку, вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: jabberd.jabberstudio.org

Решение: Установите последнюю версию с сайта производителя.

Ссылки: 3 buffer overflows in jid.c

или введите имя

CAPTCHA