Межсайтовый скриптинг в cPanel

Дата публикации:
23.06.2005
Дата изменения:
24.03.2009
Всего просмотров:
971
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
cPanel 6.x
cPanel 5.x
cPanel 7.x
cPanel 8.x
cPanel 9.x
cPanel 10.x
Уязвимые версии: cPanel 10.2.0-R82 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и получить доступ к потенциально важным данным других пользователей.

Уязвимость существует из-за недостаточной фильтрации входных данных в параметре ‘user’ сценария cpsrvd.pl. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный HTML сценарий в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]:2082/login?user=**[code]

URL производителя: www.cpanel.net

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

или введите имя

CAPTCHA