Множественные уязвимости в Calendarix Advanced

Дата публикации:
02.06.2005
Дата изменения:
28.02.2009
Всего просмотров:
2295
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2005-1864
CVE-2005-1865
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Calendarix Advanced 1.x
Уязвимые версии: Calendarix Advanced 1.5.20050501, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, выполнить произвольные SQL команды в базе данных приложения и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "catview", "id" и "year". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

3. PHP-инклюдинг возможен из-за недостаточной обработки входных данных в параметре 'calpath' сценария 'admin/cal_admintop.php'. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный php сценарий на целевой системе.

URL производителя: www.calendarix.com

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:

28.02.2009
Изменено описание уязвимостей.

Ссылки: multiple vulnerabilities in Calendarix Advanced

или введите имя

CAPTCHA