SQL-инъекция в Litecommerce

Дата публикации:
11.04.2005
Дата изменения:
24.03.2009
Всего просмотров:
1179
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
LiteCommerce 2.x
Уязвимые версии: Litecommerce

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных даных в сценарии 'cart.php'. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольные SQL команды в базе данных приложения. Примеры:

http://[target]/test/cart.php?target=category&
categor y_id='SQL_INJECTION

http://[target]/test/cart.php?target=product&
product_id='SQL_INJECTION&category_id=246

Удаленный пользователь может с помощью специально сформированного запроса получить доступ к системной информации. Пример:

http://[target]/test/cart.php?target='PHP_SCRIPT_EXPOSURE

URL производителя: www.litecommerce.com

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: LiteCommerce Sql injection and reveling errors vulnerability

или введите имя

CAPTCHA