Выполнение произвольного кода в KDE Konversation

Дата публикации:
25.01.2005
Всего просмотров:
841
Опасность:
Низкая
Наличие исправления:
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Уязвимые версии: KDE Konversation 0.15 и более ранние версии

Описание:
Несколько уязвимостей, обнаруженных в KDE Konversation, позволяют удаленному пользователю выполнить произвольный код на системе и получить доступ к паролям целевых пользователей.

Уязвимость в функции 'Server::parseWildcards' позволяет удаленному пользователю обойти ограничения и выполнить произвольные шелл-команды с привилегиями текущего пользователя.

Некоторые perl сценарии некорректно обрабатывают данные в таких параметрах как $SERVER или $TARGET. Удаленный пользователь может выполнить произвольные команды на целевой системе.

URL производителя: http://www.kde.org

Решение: Установите патч:

http://download.berlios.de/konversation/konversation-0.15.1.tar.bz2

Ссылки: Multiple vulnerabilities in Konversation

или введите имя

CAPTCHA