SQL-инъекция в vBulletin

Дата публикации:
15.11.2004
Дата изменения:
17.10.2006
Всего просмотров:
3428
Опасность:
Высокая
Наличие исправления:
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Уязвимые версии: vBulletin

Описание:
Обнаружена уязвимость в vBulletin. Удаленный атакующий может выполнить произвольный SQL код на уязвимой системе.

Уязвимость существует из-за некорректной фильтрации данных в параметре 'fsel' файла 'last.php'. Удаленный атакующий может с помощью специально сформированного HTTP запроса выполнить произвольный SQL код. Пример:

last.php?fsel=,user.password%20as%20title,u ser.%20
%20%20%20username%20as%20lastposter%20FROM%20user,
thread%20%20%20%20%20WHERE%20usergroupid=6%20LIMIT %201

ПримечаниеФайл 'last.php' является модулем стороннего разработчика. Стандартный дистрибутив приложения неуязвим.

Решение: Решение не существует на данный момент.

Ссылки: Input Validation Error in 'last.php' 3rd Party vBulletin Hack Lets Remote Users Inject SQL Commands

или введите имя

CAPTCHA