SQL-инъекция в PSCRIPT Forum

Дата публикации:
20.10.2004
Дата изменения:
15.09.2008
Всего просмотров:
26684
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Powies PSCRIPT Forum 1.x (PForum)
Уязвимые версии: PSCRIPT Forum 1.26, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в сценариях "logincheck.php", "changepass.php" и "edituser.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

URL производителя: www.powie.de

Решение: Установите последнюю версию 1.29 с сайта производителя.

Ссылки: Multiple SQL-Injection Vulnerabilities
http://www.powie.de/cms/filedb/file.php?id=80&filecat=3&eintrag=0

или введите имя

CAPTCHA