Множественные уязвимости в CuteNews

Дата публикации:
02.09.2004
Дата изменения:
26.01.2009
Всего просмотров:
2196
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2004-1659
CVE-2004-1660
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CuteNews 1.x
Уязвимые версии: CuteNews 1.3.6, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "mod" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "cutepath" в сценариях show_archives.php и show_news.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://[host]/show_archives.php?cutepath=[file]
http://[host]/show_news.php?cutepath=[file]

URL производителя: www.cutephp.com

Решение: Установите последнюю версию 1.4.1 с сайта производителя.

Журнал изменений:

26.01.2009
Изменена секция «Решение», изменено описание уязвимостей.

Ссылки: RE: CuteNews News.txt writable to world

или введите имя

CAPTCHA