Переполнение буфера в Apache mod_proxy

Дата публикации:
12.06.2004
Дата изменения:
29.03.2008
Всего просмотров:
3018
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apache 1.3.x
Уязвимые версии: Apache 1.3.31 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в файле proxy_util.c в модуле mod_proxy. Удаленный пользователь может с помощью специально сформированного HTTP запроса, содержащего отрицательное значение в заголовке "Content-Length:", вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.apache.org

Решение: Установите последнюю версию 1.3.32 с сайта производителя.

Ссылки: Buffer Overflow in Apache mod_proxy

или введите имя

CAPTCHA