Удаленное переполнение буфера в ISS Proventia, ISS BlackICE и ISS RealSecure

Дата публикации:
29.02.2004
Всего просмотров:
1146
Опасность:
Критическая
Наличие исправления:
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Уязвимые версии: ISS Proventia A Series XPU 20.15 - 22.9; Proventia G Series XPU 22.3 - 22.9; Proventia M Series XPU 1.3 - 1.7
ISS BlackICE PC Protection 3.6 cbr through ccb; BlackICE Server Protection 3.6 cbr - ccb
ISS RealSecure Network 7.0, XPU 20.15 - 22.9; Server Sensor 7.0 XPU 20.16 - 22.9; Desktop 7.0 eba - ebh; Desktop, Guard, и Sentry 3.6 ebr - ecb

Описание: Уязвимость обнаружена в нескольких продуктах от ISS в обработке Server Message Block (SMB) пакетов. Удаленный пользователь может выполнить произвольный код на целевой системе.

Уязвимость обнаружена в ISS Protocol Analysis Module (PAM) компоненте, которую используют несколько программ от ISS. Переполнение обнаружено при обработке пакета "SMB Session Setup AndX request" с параметром AccountName, размером более 300 байт.

Удаленный пользователь может представить специально обработанный SMB пакет, чтобы заставить целевую систему выполнить произвольный код при попытке обработать этот пакет.

URL производителя: http://www.iss.net/

Решение:Установите обновленные версии уязвимых программ: http://www.iss.net/download

Ссылки: ISS Security Brief: Vulnerability in SMB Parsing in ISS Products

или введите имя

CAPTCHA