Межсайтовый скриптинг через PHPSESSID URI параметр в PHP

Дата публикации:
03.06.2003
Всего просмотров:
1621
Опасность:
Наличие исправления:
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Описание: Уязвимость обнаружена в языке сценария PHP. Удаленный пользователь может выполнить XSS нападение.

Проблема связанна с недостаточной фильтрацией PHPSESSID URI параметра. Атакующий может эксплуатировать эту уязвимость, используя специальную ссылку, содержащую произвольный код сценария, введенный в эту переменную. Уязвимость может использоваться для выполнения произвольного кода сценария в контексте уязвимого сайта. Пример:

http://www.example.org/index.php?PHPSESSID="><script>...</script>
Уязвимость обнаружена в PHP 4.0-4.3.1

Ссылки: Cross-site Scripting in PHP's Transparent Session ID Support
или введите имя

CAPTCHA