Повышение привилегий в нескольких SAP DB утилитах

Дата публикации:
28.04.2003
Всего просмотров:
703
Опасность:
Наличие исправления:
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Описание: Уязвимость обнаружена в SAP DB в нескольких вспомогательных утилитах, поставляемых с сервером. Локальный пользователь может получить root привилегии.

Сообщается, что вспомогательные утилиты 'bin/instdbmsrv' и 'bin/instlserver' выполняют 'chmod' ownership модификацию на 'pgm/lserver' файле, используя путь, заданный пользователем в переменной $INSTROOT. Локальный пользователь может создать свой 'lserver' файл, установить $INSTROOT переменную к пути, в котором распложен 'lserver' файл, и запустить уязвимые perl утилиты. После этого, локальный пользователь может выполнить свой 'lserver' файл с root привилегиями, чтобы получить root доступ к системе.

Уязвимость обнаружена в SAP DB Helper 7.x

Ссылки: SAP DB Development Tools install flaw

или введите имя

CAPTCHA