Отказ в обслуживании в Apache HTTP сервере

Дата публикации:
09.04.2003
Дата изменения:
19.05.2009
Всего просмотров:
1137
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apache 2.0.x
Уязвимые версии: Apache 2.0.44 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести DoS атаку.

Уязвимость существует из-за ошибки при обработке исключений, которая приводит к тому, что приложение выделяет 80 байт памяти для каждого символа новой строки, который был найдет в HTTP запросе. Удаленный пользователь может с помощью специально сформированных HTTP запросов заставить приложение потребить всю доступную память на системе и вызвать отказ в обслуживании.

URL производителя: www.apache.org

Решение: Установите последнюю версию 2.0.45 с сайта производителя.

Журнал изменений:

19.05.2009
Изменено описание уязвимости.

Ссылки: iDEFENSE Security Advisory 04.08.03: Denial of Service in Apache HTTP Server 2.x
http://www.kb.cert.org/vuls/id/206537
http://www.apache.org/dist/httpd/CHANGES_2.0

или введите имя

CAPTCHA