Переполнение буфера в SCO UnixWare/Open UNIX

Дата публикации:
15.01.2003
Дата изменения:
17.10.2006
Всего просмотров:
651
Опасность:
Наличие исправления:
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Описание: Локальное переполнение буфера обнаружено в SCO UnixWare/Open UNIX ps утилите.

Уязвимость связанна с недостаточной проверкой параметров командной строки. Хотя эта утилита и не установлена как setuid/setgid, она используется функцией procprivl(SETPRV,pm_work(P_MACREAD), которая позволяет выполнять произвольный код с поднятыми привилегиями.

Уязвимость обнаружена в Caldera OpenUnix 8.0, Caldera UnixWare 7.1.1

или введите имя

CAPTCHA