Межсайтовый скриптинг в VBulletin

Дата публикации:
26.11.2002
Всего просмотров:
2102
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
vBulletin 2.x
Описание: vBulletin – популярная доска объявлений.

vBulletin не фильтрует HTML тэги в некоторых URI параметрах. В результате, удаленный атакующий может сконструировать злонамеренную ссылку, содержащую код сценария, который будет выполнен в браузере пользователя, кликнувшего на эту ссылку, в контексте уязвимого сайта. Уязвимость может использоваться для кражи опознавательных мандатов, хранящихся в куки. Пример:

http://www.vbulletin.com/forum/memberlist.php? 
s=23c37cf1af5d2ad05f49361b0407ad9e&what=">" 
<Scr*ipt>javascript:alert(document.cookie)</Scr*ipt>
Уязвимость обнаружена в VBulletin 2.0-2.2.9

Ссылки: XSS bug in vBulletin
эксплоит
или введите имя

CAPTCHA