Недостаточная проверка границ в нескольких IPv4 утилитах и в pppd службе в NetBSD

Дата публикации:
20.09.2002
Всего просмотров:
1096
Опасность:
Наличие исправления:
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Описание: NetBSD сообщил о переполнении буфера в нескольких IPv4 утилитах и в pppd службе. Уязвимыми оказались демоны mrinfo(1), mtrace(1) и pppd(8).

Эти утилиты используют select (2). select (2) использует fd_set bitmap, который поддерживает до FD_SETSIZE (256) файловых дескрипторов. Переполнение буфера – результат недостаточной проверки границ, при выполнении FD_SET() операции. Если дескриптор файла, используемый для select (2), равен или превышает FD_SETSIZE, происходит переполнение буфера.

Уязвимость обнаружена в NetBSD NetBSD 1.4-1.5.3

или введите имя

CAPTCHA