Выполнение произвольных команд в phpPgAdmin

Дата публикации:
25.01.2002
Дата изменения:
09.12.2008
Всего просмотров:
854
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpPgAdmin 2.x
Уязвимые версии: phpPgAdmin 2.2.1 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за недостаточной обработки входных данных в сценарии sql.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные команды на системе с привилегиями Web сервера.

URL производителя: phppgadmin.sourceforge.net

Решение: Установите последнюю версию 2.3 с сайта производителя.

Ссылки: http://prdownloads.sourceforge.net/phppgadmin/phpPgAdmin_2-4.tar.gz
http://phppgadmin.sourceforge.net/?page=home

или введите имя

CAPTCHA