Вышла обновленная версия ядра Linux

image

Теги: Linu

Как отмечает Торвальдс, в Linux 2.6.22 устранены ряд проблем, связанных с драйверами, а также сетевыми подключениями.

Линус Торвальдс, создатель открытой операционной системы Linux, сообщил о выпуске обновленной версии ядра этой программной платформы, получившей индекс 2.6.22.

Как отмечает Торвальдс, в Linux 2.6.22 устранены ряд проблем, связанных с драйверами, а также сетевыми подключениями. Кроме того, разработчики внесли незначительные изменения в архитектуру операционной системы и реализовали два новых алгоритма контроля перегрузки TCP. Найти дополнительную информацию об обновленной версии ядра, а также загрузить исходные коды можно отсюда.

Между тем, в анонсе новой версии ядра Linux Торвальдс ни слова не упоминает о возможности перевода операционной системы под третью версию лицензии GNU GPL. Окончательная модификация GPLv3, напомним, была обнародована на прошлой неделе. Кстати, Торвальдс изначально высказывался против новой версии GPL. По мнению создателя Linux, в GPLv3 нет фундаментальных изменений, которые могли бы подтолкнуть к обновлению лицензии на ядро открытой операционной системы.

Тем не менее, по оценкам экспертов компании Palamida, с течением времени на GPLv3 будут переведены до 5500 проектов. Кстати, проект GNU, как ожидается, будет полностью переключен на GPLv3 до конца текущего месяца.


или введите имя

CAPTCHA
12-07-2007 14:49:30
по теме - наворачиваются слезы радости
0 |
13-07-2007 10:36:28
жуть, секлаб превращается в сбореще дебилов, по теме: 1) Линус Торвальд не создатель ОС, он создал только ядро 2) Нет ОС Линукс, есть GNU/Linux 3) Какого xpена делать из этого новость, обновления выходят почти каждый день и вообще це бoян! linux-2.6.21.6.tar.bz2 07-Jul-2007 04:47 42M linux-2.6.22.tar.bz2 08-Jul-2007 23:48 43M linux-2.6.22.1.tar.bz2 10-Jul-2007 19:24 43M
0 |
1
12-07-2007 15:03:51
Чорт! Как домой-то идти. Везде пьяные линуксоиды праздновать будут.
0 |
12-07-2007 15:15:53
страшно? ууууууу
0 |
1
12-07-2007 15:05:48
на секлабе стали постить ченьжлоги... пипец, куда мир катится.. пол темы - ченжлог, вторые полтемы - пара несвязанных слов о gplv3 который вх[]й не впился.
0 |
1
13-07-2007 14:56:20
Ничего. Это хорошо. Теперь драйверы, написанные для старых версий ядра работать не будут... Это сделает Линукс еще "популярнее". И как это у меня в 2003-ем пашет принтер на драйверах от NT4?
0 |
R
13-07-2007 15:32:57
Теперь драйверы, написанные для старых версий ядра работать не будут...Если они открытые, то будут работать и через двадцать лет с новым ядром. И как это у меня в 2003-ем пашет принтер на драйверах от NT4?NT и не развивается так, как развивается Linux, потому что закрытые драйвера это балласт, который не позволяеют ничего кардинально изменить. А Linux - система открытая, с открытыми драйверами(закрытые драйвера вне закона, т.к. код ядра GPL-ный) что позволяет концентрироваться на развитии и улучшении, а не заморачиваться с костылями, грязными хаками и воркэраундами для обеспечения бинарной совместимости ядерного API с драйверами, которая так важна для закрытых систем с закрытыми драйверами. ЗЫ А vxd-драйвера от Win9x на NT слабо завести? А драйвера, существующие только в 32-битном варианте на 64-битной платформе? А если других нет? А в линуксе открытые драйвера и от версии 2.4 и от версии 2.2, да хоть от версии 0.01 заведутся после модификации исходников, да не на одной процессорной архитектуре.
0 |
1
13-07-2007 16:23:34
спасибо за очередную рекламу linux. Благодаря линуксойдам остальные людио тчаянно ненавидят эту систему, как любой человек вознинавидит то, к чему его насильно принуждают и бесцеремонно навязывают.
0 |
R
13-07-2007 20:57:49
Вас кто-то насильно заставляет читать топик "Вышла обновленная версия Linux" и заставляет ставить эту ОС? как любой человек вознинавидит то, к чему его насильно принуждают и бесцеремонно навязывают.Я думал это относится к системе производства MS, которую навязывают начиная от закрытых форматов MSO, закрытыми официальными драйверами, навязывают win32-программами, навязывают на баннерах, навязывают в магазине, навязывают школам.
0 |
1
13-07-2007 16:56:02
vxd - это как раз костыль платформы 9x. И к NT эта платформа отношения не имеет. Вы хоть видели эут самую 64-битную XP/2003? Можете объяснить, чем она лучше 32-битной с цифрами в руках, а не голой теорией? Ключевое слово ПОСЛЕ МОДИФИКАЦИИ ИСХОДНЫХ КОДОВ, для чего надо обладать квалификацией СИСТЕМНОГО ПРОГРАММИСТА под Linux. Мне же ничего для запуска старых драйверов не требуется. Максимум - одну строчку в inf поправить. Linux - это балласт, т.к. его фанаты генерируют кучу необоснованного бреда.
0 |
1
13-07-2007 17:00:07
Если же говорить о других архитектурах, то есть Windows CE(массово выпускается под ARM, MIPS, SH3,SH4 и т.п.), которой благодаря КПК и смартфонам все равно больше, чем убогого Линукса. И софта под Windows CE тоже больше, а качество его - лучше. Как хорошо сказал один мой знакомый - опен-сорс - это куча дерьма в тарболлах.
0 |
R
13-07-2007 22:59:20
Если же говорить о других архитектурах, то есть Windows CE(массово выпускается под ARM, MIPS, SH3,SH4 и т.п.) Кстати, как там насчет совместимости ядра WinCE с драйверами от NT? которой благодаря КПК и смартфонам все равно больше, чем убогого Линукса.Точки WiFi доступа, маршрутизаторы, DSL-модемы, SAN-сервера, контроллеры СКД и иного назначения, приставки, видеорегистраторы, роботы, КПК и телефоны с Linux тоже посчитали? Как хорошо сказал один мой знакомый - опен-сорс - это куча дерьма в тарболлах.На которой почти все суперкомпьютеры и большая часть Интернета держится. И зачем только Google, IBM, Redhat, Novell, HP, Intel, AMD, Siemens, Fujitsu, Nokia, Toshiba и другие... с ним мучаются. )))
0 |
R
13-07-2007 22:25:06
vxd - это как раз костыль платформы 9x. И к NT эта платформа отношения не имеет.Ну и что? Драйвера под Windows? Под Windows. А почему на новых версиях Windows не работают и что сделать чтобы заработали? В Linux почему-то такой проблемы нет - драйвера открытые, поэтому они легко портируются. Можете объяснить, чем она лучше 32-битной с цифрами в руках, а не голой теорией?Зачем что-то объяснять? По техническим характеристикам 64-битная архитектура лучше, снимает ряд 32-битных ограничений, не требует тормозных костылей PAE для поддержки объемов памяти более 3ГБ, обладает удвоенным количеством РОН и SIMD-регистров, что дает серьезное увеличение производительности на оптимизированном коде. Просто можно констатировать факт, что 64-битная закрытая ОС на родном 64-битном железе имеет проблемы с отсутсвием 64-битных драйверов для неподдерживаемого железа, в то время как открытая система уже давно портировала старые 32-битные драйвера на 64-битную архитектуру. А это подтверждает факт, что открытые системы намного более гибкие, адаптируемые и перспективные, чем закрытые. Ключевое слово ПОСЛЕ МОДИФИКАЦИИ ИСХОДНЫХ КОДОВ, для чего надо обладать квалификацией СИСТЕМНОГО ПРОГРАММИСТА под Linux.Их портируют мантейнеры ядра, не мантейнеры ядра - так дистрибьюторы или кто другой. Например, для множества железок в Linux уже были стабильные 64-битные драйвера задолго до появления официальных закрытых 64-битных для NT, а Linux был портирован на x86_64 примерно за год до NT. А с VXD-драйверами или 32-bit only закрытыми драйверам для снятой с поддержки железки вариантов нет. Мне же ничего для запуска старых драйверов не требуется. Максимум - одну строчку в inf поправить.При появлении NT5.1 первым делом отвалился ряд драйверов. Например, отвалились драйвера HASP, исправно работавшие на W2k и никакой волшебной строчкой в inf это не лечилось. Помнится, NT4-драйвера Winroute валили NT5.0, некоторые NT4 драйвера отказывались ставиться на W2k. Поэтому хватит ездить по ушам. Я не думаю, что стабильное ядерное API это плохо, но здесь приходится выбирать - или неограниченные возможности внесения глубоких изменений в ядро, что позволяет Linux стремительно развиваться или совместимость+медленное развитие+невозможность устранить концептуальные дефекты без костылей и грязных хаков. Linux - это балласт, т.к. его фанаты генерируют кучу необоснованного бреда.Только красноглазые фанаты NT могут радоваться тому, что драйвера принтера, а еще код GDI и код обработки оконных сообщений болтаются в режиме ядра и чуду, что драйвера от NT4 подходят для NT5. В Linux драйвера принтера работают в пользовательском режиме, а не как у некоторых, а значит абсолютно не зависят от ядерного API и не могут влиять на стабильность системы.
0 |