Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
проблема с Gentoo
 
HI =))
Решил перейти с Fedora Core на Gentoo, с установкой системы проблем не было (я ставил все по русским манам с gentoo.org) но вот при загрузке выдает мне сначала ошибку в /sbin/rc строка 271 - нет файла /sbin/devfsd (если не ошибаюсь), загружается дальше, но валится с ошибкой "Bad superblock on /dev/hda2"
ядро - 2.6.9 с проверенным конфигом
файловая система EXT3, хотя пробовал разные
загрузчик - LILO
может кто поможет =))
 
Что есть /dev/hda2? Где корень системы? Вобщем грузись с liveCD и подавай инфу в студию - сколько разделов и что где(fdisk /dev/hda, затем p), конфиг лило и т.д.
 
/dev/hda1 - Win
/dev/hda2 - / (ext3)
/dev/hda3 - swap

конфиг лило стандартный, делел по образцу (lilo.conf.example)

boot=/dev/hda
prompt
timeout=50
default=gentoo

image=/boot/bzImage
label=gentoo
read-only
root=/dev/hda2
 
А ты случаем не вкомпилировал в ядро devfs (CONFIG_DEVFS_FS)?
 
в конфиге ядра включены devfs

"Включите файловые системы VM, /proc fs, /dev fs, монтирование /dev fs автоматически при загрузке"
(по манам с gentoo.org/doc/ru/gentoo-x86-quickinstall.xml)
 
А /sbin/devfsd точно нет? Если нет - заемерж emerge devfsd

$ which devfsd|xargs sudo equery belongs
[ Searching for file(s) /sbin/devfsd in *... ]
sys-fs/devfsd-1.3.25-r8 (/sbin/devfsd)
$

А, вообще, задумайся над переходом на udev, т.к. с devfsd были нек-рые приколы(вроде матов на unable to unlink vcc/x), а сейчас devfs не сопровождается, т.к. будущее за udev, но при переходе на udev нужно отключить автомонтирование devfs.
 
Давно сижу на udev под федорой.... вчера поставил на гентуу
делел так :
mount /dev/hda2 /mnt/gentoo
chroot /mnt/gentoo /bin/bash
emerge udev
но не перекомпилил ядро, не отключал поддержку devfsd
 
Сейчас то все нормально после отключения автомонтирования DEVFS?
 
неа
пишет "немогу смонтировать / для чтения-записи", пишет, что надо запустить проверку e2fsck, но это не помогает.
если нажать ctrl+D - загружается до конца (до ввода логина)
какой то я не везучий
 
Цитата
= FreeMAN = пишет:

но не перекомпилил ядро, не отключал поддержку devfsd
можно без перекомпиля

Lilo examples:

Option 1: Dont load devfs, use udev.
     image ="/boot/bzImage"
     root="/dev/hda2"
     label="GentooUDEV"
     append = "gentoo=nodevfs"
     read-only

и наоборот

Option 2: Dont load udev, use devfs.
     image ="/boot/bzImage"
     root="/dev/hdа2"
     label="GentooDEVFS"
     append = "gentoo=noudev"
     read-only

Цитата
= FreeMAN = пишет:

Включите файловые системы VM, /proc fs, /dev fs, монтирование /dev fs автоматически при загрузке"
(по манам с gentoo.org/doc/ru/gentoo-x86-quickinstall.xml)

CONFIG_SYSFS=y

в конфиге?
и еще , мож у тебя че в fstab напутано ...
 
Спасибо за помощь =)
Нашел неполадку - в каталоге /dev НЕТ НИ ОДНОГО устройства.... я был в шоке =))
криво монтируется или вообще не пашет udev
Страницы: 1
Читают тему (гостей: 1)